Tuesday, August 30, 2011

Project Server 2010 - PWA Creation Failed

When trying to provision a new PWA. It fails on Provisioning Databases stage. Event
viewer records the below errors,

Microsoft.Office.Project.Server.Administration.ProvisionException: Failed to provision databases. ---> Microsoft.Office.Project.Server.Administration.ProvisionException: IF NOT EXISTS (SELECT name FROM sysusers WHERE name = N'ProjectServerRole' and issqlrole = 1)
EXEC sp_addrole N'ProjectServerRole', N'dbo'
---> System.Data.SqlClient.SqlException: User does not have permission to perform this action.

Root cause: The farm account used to execute the PWA creation command does not have sysadmin privileges on the database instance.

Solution: In our environment no account is allowed sysadmin privileges, although it is clearly mentioned as a requirement for Project Server 2010, http://technet.microsoft.com/en-us/library/cc197607.aspx
We have decided to grant the farm account db_owner permissions manually on each of the 4 pwa databases and then Retry the provision process.

Sunday, August 28, 2011

SP2010 Workflow Events


Start a new workflow based on completion of a different workflow.


Use SPWorkflowEventReceiver class

- WorkflowStarting - A workflow is starting
- WorkflowSterted - A workflow was started
- WorkflowPostponed - A workflow was postponed - WorkflowCompleted - A workflow was completed

Friday, August 26, 2011

SP2010 Activity Feed / News Feed

News feeds are populated using a job in Central Administration -> Monitoring -> Review job definitions -
> [User Profile Service Application] - Activity Feed Job

Tuesday, August 23, 2011

Exam 70-573

This is just an incredible resource to study for Exam 70-573.

SharePoint 2007 Site Template list does not exist

User creates a site template in a publishing site collection (using the old trick of navigating directly to save site as template page). This site template includes CEWP's which point to static images as placeholders. When a new site is created using the template, everything works fine except,
a. Site Settings -> Modify Navigation results in "List not found" error
b. Edit CEWP and try to change the placeholder image to a valid image -> List not found error

Navigate to Site Settings -> Modify Navigation
Error occurs
REFRESH page !

All the CEWP's start working. I have not yet identified the root cause of this issue. Reflector should be able to help. My feeling is that the publishing infrastructure adds some link pointers in the site template as GUIDs which cannot be found after the new site is created using the template.

UPDATE: This could be a possible explanation,

Monday, August 22, 2011

SharePoint SSL

Setup SSL for existing HTTP SharePoint web site.

1. SelfSSL, Entrust -> assign certificate
2. If only SSL is required, then drop current IIS website ONLY
3. If multiple websites require SSL on same server, use multiple IPs
4. Alternate access mappings:
Zone: default
https -> https
http -> https
5. Also note F5 is used to offload SSL.
6. Once SSL is configured setup required AAM's and re-configure search settings.

Sunday, August 21, 2011

Connect Ubuntu and PS3

Need to use ubuntu machine as a media server for PS3.

Use mediatomb

1. This link explains almost all steps in detail,

1. Media Tomb icon is not displayed in PS3 under videos, music or pictures.
Ans: Restart media server (computer) and PS3.

2. Media Tomb icon is displayed but only PC directory is shown although you have shared appropriate folder from computer and mediatomb is working.
Ans: Restart PS3

Thursday, August 18, 2011

SharePoint .NET SAML

Want to use .net to create SAML token ?

Refer these links,


Tuesday, August 16, 2011

SP2010 - Difference between v2v and b2b

Difference between v2v and b2b,
•A v2v upgrade is used for upgrading from one product version to another (e.g. MOSS 2007 to SharePoint Server 2010).
•A b2b upgrade is used for upgrading from one build to another within the same product version (e.g. SP2010 RTM to SP2010 SP1).

Sunday, August 14, 2011

Hide ribbon from annonymous users - SP 2010

Use this link info to hide ribbon effectively from annonymous users. It also resolves the scrollbar issue,

If you want authenticated users to see the ribbon then you have multiple options,
1. Move the "welcome user" to another location on the page.
2. Provide a new link that points to /_layouts/authenticate.aspx which will open up IE login window.

Tuesday, August 9, 2011

SharePoint 2010 SP1 and June CU

1. Logon, as the setup account to perform all the operations
2. Run the SharePoint configuration Wizard to check that everything is OK in the Farm
3. Checked the existence of an up to date Full SharePoint Farm backup, if not take one now, before the update, just in case something goes wrong.
4. Took a full SharePoint Farm backup using Central administration
5. Installed the SharePoint Foundation SP1 package (sharepointfoundation2010sp1-kb2460058-x64-fullfile-en-us.exe)
6. Rebooted server (as requested by previous installation)
7. Installed the SharePoint Office Server SP1 package (officeandprojectserver2010sp1-kb2460047-x64-fullfile-en-us.exe)
8. Rebooted server (as requested by previous installation)
9. Installed the SharePoint Foundation June CU package (sharepointfoundation2010-kb2536601-fullfile-x64-glb.exe)
10. Rebooted server (as requested by previous installation)
11. Installed the SharePoint Office Server June CU package (office2010-kb2536600-fullfile-x64-glb.exe)
12. Run the SharePoint 2010 Products Configuration wizard on central admin server