Wednesday, June 6, 2012


SharePoint search - Reduce network traffic

Scenario: is an intranet site is hosted on an internal Server 1. The host file on server has an entry to make sure all requests made to hostname1 points to the same server, hostname1
However each time the SharePoint search crawler runs all requests made to http://hostname1 is first made to the proxy which then redirects it back to Server 1 which unnecessarily increases load on the network and the proxy introducing performance issues.

- Review the corporate proxy script (if you have one) used for IE on the server and make sure it does not send intranet request to the proxy.

- If the above does not solve the problem, follow below steps
        => Grant search content access local server rdp access on Server 1
        => Login to the server with the search content access account 
        => Open IE and uncheck "Automatically detect proxy"
        => Remove the search content access account rdp access to Server 1
I am very sure the above steps can be handled differently by editing the registry for the local machine which is something I was not able to uncover so far.

Project Server 2010 Quick Launch

Hide quick launch entries on Project Server 2010 web access site does not work. Navigate to Server Settings -> Quick Launch -> "Quick Launch Item" -> Display on Quick launch -> No -> OK and Save.

This is a very strange problem and is observed when you have Publishing infrastructure activated on the pwa site. Navigate to Site Settings -> Navigation -> Click OK.

If you have already hidden the quick launch item from Project Server 2010 and it still shows up then after performing the above steps it should now become invisible. I think this is a bug in the product.


Tuesday, June 5, 2012

Project Server 2010 - Delegation error

Users are presented with the below error message when they navigate to PWA homepage on a Project Server 2010 web instance.

You do not have sufficient permissions to view the specified page. Please contact your administrator for permissions to view this page.

This situation can happen when there are several delegations setup for a particular user and some of the accounts used in the setup are either inactive now or do not have any security permissions.

Remove the incorrect delegations for the user account which is facing this error. 

If you do not see any delegations when you click on "Manage Delegations" link under "Personal Settings" then permissions are not correctly set. To set the correct permissions, follow below steps,
- Click on "Server Settings"
- Click on "Manage groups"
- Click on the group that includes the current account.
- Under Categories section click on any category, in my case it was "My Organization"
- Permissons for "My Organization" will open. Now make sure 'Manage Resource Delegates' is enabled under Resource section and hit Save.
- Also make sure that the current Group permission have the same option enabled.
This link provides all details,